PebblePad Personal Learning Environment (PLE) browser compatibility

Do I need to configure my browser for PebblePad?

The version of PebblePad used at UWA supports most common browsers, with Flash Player installation required. You can use a flash-free (HTML) version on your tablet or other devices.

To check whether your browser is compatible visit the PebblePad browser check page.

Was this answer helpful?
Your rating has been submitted; please tell us how we can make this answer more useful.